Linux下gsoap的安装

文章来源:http://www.codelast.com/


系统:RHEL 5.1 & 5.3

gsoap是个好东东,它可能很好装,可能也很难装,取决于你的系统已经安装了什么开发包。

我在多台RHEL虚拟机(32bit & 64bit)上均安装了gsoap,其中有一台是configure之后直接make就搞定了,另外两台都是还要折腾很多其他东西的。

其中有几个需要说明的地方是:

(1)安装gsoap,你需要先安装openssl-devel,byacc-devel,bison-devel等开发包,如果你不知道你是否已经安装了,请用rpm -qa命令来查询(仅针对使用rpm包安装的),例如,命令: rpm -qa | grep openssl 将查询出与openssl相关的rpm包安装信息。

(2)当你make的时候,在最后即将结束时,遇到 /usr/bin/ld: cannot find -ly 错误的话,请安装 bison-devel 开发包(这个比较不容易看出来),我是用RHEL的rpm装的。

(3)一次make失败后,请重新 ./configure,然后make clean,然后再make。

文章来源:http://www.codelast.com/

发表评论

电子邮件地址不会被公开。 必填项已用*标注